Varatut IP-osoitealueet
Osoitelohkot, jotka eivät ole tavallisia julkisia osoitteita, IANA:n erikoisosoiterekistereistä – ja tarkistus, joka kertoo, mihin lohkoon osoite kuuluu.
100.64.12.7 kuuluu lohkoon 100.64.0.0/10: Jaettu osoitealue (CGNAT).
IPv4:n erikoislohkot
| Lohko | Tarkoitus | Määritelty | Tavoitettavissa internetistä |
|---|---|---|---|
| 0.0.0.0/8 | MäärittelemätönTämä verkko | RFC 791 | Ei |
| 10.0.0.0/8 | Yksityinen verkkoYksityiskäyttö | RFC 1918 | Ei |
| 100.64.0.0/10 | Jaettu osoitealue (CGNAT)Jaettu osoiteavaruus (CGNAT) | RFC 6598 | Ei |
| 127.0.0.0/8 | LoopbackLoopback | RFC 1122 | Ei |
| 169.254.0.0/16 | Linkkikohtainen (link-local)Linkkikohtainen | RFC 3927 | Ei |
| 172.16.0.0/12 | Yksityinen verkkoYksityiskäyttö | RFC 1918 | Ei |
| 192.0.0.0/24 | ProtokollakäyttöIETF:n protokollavaraukset | RFC 6890 | Ei |
| 192.0.2.0/24 | DokumentaatioDokumentaatio (TEST-NET-1) | RFC 5737 | Ei |
| 192.31.196.0/24 | AnycastAS112-v4 | RFC 7535 | Kyllä |
| 192.52.193.0/24 | ProtokollakäyttöAMT | RFC 7450 | Kyllä |
| 192.88.99.0/24 | VarattuVanhentunut 6to4-välittäjien anycast | RFC 7526 | Ei |
| 192.168.0.0/16 | Yksityinen verkkoYksityiskäyttö | RFC 1918 | Ei |
| 192.175.48.0/24 | AnycastAS112-palvelun suora delegointi | RFC 7534 | Kyllä |
| 198.18.0.0/15 | SuorituskykytestausSuorituskykytestaus | RFC 2544 | Ei |
| 198.51.100.0/24 | DokumentaatioDokumentaatio (TEST-NET-2) | RFC 5737 | Ei |
| 203.0.113.0/24 | DokumentaatioDokumentaatio (TEST-NET-3) | RFC 5737 | Ei |
| 224.0.0.0/4 | Ryhmälähetys (multicast)Ryhmälähetys | RFC 5771 | Ei |
| 240.0.0.0/4 | VarattuVarattu tulevaan käyttöön | RFC 1112 | Ei |
| 255.255.255.255/32 | Yleislähetys (broadcast)Rajattu yleislähetys | RFC 919 | Ei |
IPv6:n erikoislohkot
| Lohko | Tarkoitus | Määritelty | Tavoitettavissa internetistä |
|---|---|---|---|
| ::/128 | MäärittelemätönMäärittelemätön osoite | RFC 4291 | Ei |
| ::1/128 | LoopbackLoopback-osoite | RFC 4291 | Ei |
| ::ffff:0:0/96 | MuunnosIPv4-mapped-osoite | RFC 4291 | Ei |
| 64:ff9b::/96 | MuunnosIPv4–IPv6-muunnos (NAT64) | RFC 6052 | Kyllä |
| 64:ff9b:1::/48 | MuunnosPaikallinen IPv4/IPv6-muunnos | RFC 8215 | Ei |
| 100::/64 | VarattuVain hylättäväksi tarkoitettu lohko | RFC 6666 | Ei |
| 2001::/32 | MuunnosTEREDO | RFC 4380 | Ei |
| 2001:2::/48 | SuorituskykytestausSuorituskykytestaus | RFC 5180 | Ei |
| 2001:db8::/32 | DokumentaatioDokumentaatio | RFC 3849 | Ei |
| 2001:10::/28 | VarattuVanhentunut (ORCHID) | RFC 4843 | Ei |
| 2001:20::/28 | ProtokollakäyttöORCHIDv2 | RFC 7343 | Kyllä |
| 2002::/16 | Muunnos6to4 | RFC 3056 | Ei |
| 3fff::/20 | DokumentaatioDokumentaatio | RFC 9637 | Ei |
| 5f00::/16 | ProtokollakäyttöSegmenttireitityksen (SRv6) SID:t | RFC 9602 | Ei |
| fc00::/7 | Yksilöllinen paikallinen (ULA)Yksilöllinen paikallinen | RFC 4193 | Ei |
| fe80::/10 | Linkkikohtainen (link-local)Linkkikohtainen yksittäislähetys | RFC 4291 | Ei |
| ff00::/8 | Ryhmälähetys (multicast)Ryhmälähetys | RFC 4291 | Ei |
Koottu IANA:n IPv4- ja IPv6-erikoisosoiterekistereistä sekä multicast- ja vanhasta E-luokan alueesta. ”Tavoitettavissa internetistä” noudattaa IANA:n saraketta ”globally reachable”. Yksityistä osoitetta ei koskaan reititetä julkisessa internetissä.
Aiheeseen liittyvää
- IP-osoitteen tarkistusOnko osoite kelvollinen, ja millainen osoite se on.
- CIDR-laskuriVerkko-osoite, broadcast, peitteet ja osoitemäärät mille tahansa prefiksille.
- IP-osoitteen hakuASN, operaattori, reitti, käänteinen DNS ja sijainti mille tahansa osoitteelle.
- IPv4 → IPv6IPv4-mapatut, 6to4- ja NAT64-esitysmuodot.